1. The WordReference Forums have moved to new forum software. (Details)

activate / deactivate thread title mouseover preview

Discussion in 'Comments and Suggestions' started by EStjarn, Jan 19, 2013.

  1. EStjarn

    EStjarn Senior Member

    Spanish
    Hi,

    I normally don't use the thread title mouseover preview feature. Is it possible to unselect it?
     
  2. jann

    jann co-mod'

    English - USA
    No, not to my knowledge. But if you don't use it, why does the fact that it exists bother you? :confused:
     
  3. EStjarn

    EStjarn Senior Member

    Spanish
    Well, scrolling with the keyboard, it is sometimes annoying to have chunks of text you haven't requested consistently pop up on the screen - one new preview for each key stroke. Depending on where the mouse pointer is located during the scrolling, and on the size of the preview boxes, each preview may block, partly, the view (and thus the hyperlink) of one or several thread titles.

    The previews can be avoided by keeping the pointer always to the right of the thread title field; but that's not really a natural place for it when opening threads. If the option to deactivate this feature existed, it would, I believe, make the scrolling/thread-opening experience more streamlined for non-preview users.
     
  4. jann

    jann co-mod'

    English - USA
    Interesting.

    In Firefox, I cannot reproduce the issue you describe.

    I habitually use the scrolling region on my laptop's touchpad to scroll. When I use this method, the mouse pointer must stop somewhere within the white box containing the thread title before the tooltip-style preview pane opens. Now if a preview appeared for every single title I scrolled over, I agree that it would be very annoying... but this doesn't happen to me because the mouse is always moving during normal scrolling behavior. As a result, I see the preview for the last thread only, where my mouse finally stops at the end of the scroll.

    I also tested using my keyboard arrow keys to scroll. I use this method too, but less frequently. In Firefox, the mouse pointer remains visible while scrolling with the arrorws... but the mouseover preview is not activated at all. I can deliberately stop the arrow-key-initiated scroll at a place on the page that leaves the mouse pointer hovering directly over a thread title, and I still don't see the preview.

    It sounds like different browsers may behave differently. If you're getting a tooltip-style preview for every single thread title you scroll across at normal (fast) scrolling speed when you use your arrow keys to scroll, that sounds undesirable. But it also sounds like behavior you would expect to see on all websites that use tooltips or previews, and so it's just our forum layout that makes it annoying here on WR.

    I suspect this is something you could configure within your own browser. Firefox allows you to disable tooltips entirely on all sites using the about:config page (info here; you can always re-enable), and I think you could potentially disable them on WR only by editing your usercontent.css file. Chrome will also let you specify preferences (and presumably disable tooltips on some or all sites) via a user-based .css fie, but you have to download and install an extension like Stylist in order to edit your .css file. I don't use Chrome, personally.
     
  5. EStjarn

    EStjarn Senior Member

    Spanish
    Thanks for a thorough answer.
    It's good that you mention this. I've never gotten into the habit of using the touchpad for scrolling. Now that I try it again, I agree that it's just like you say: no previews are showing until the pointer stops.
    I suppose there are different kinds of scrolling for different purposes, perhaps simplified as fast-scrolling and slow-scrolling. When you say the mouse is always moving, it sounds as though you're describing fast-scrolling (or at least not slow-scrolling). I realize I should have said it is primarily when I slow-scroll, using up/down arrow keys, that the browser behavior described above sometimes becomes an issue. Such scrolling typically involves stopping a moment (often less than half a second) after each key stroke.
    Interesting. So that would be a second work-around: change to Firefox. Now I probably won't do that as it would represent too drastic a step: I was originally hoping for a simple tick-box solution. But it's nice to know that the results are different with different browsers, being a Chrome user myself.
    Will do.
     

Share This Page