Context menu not appearing on Android phone

Sterile Frogs

New Member
I no longer get the option for Wordreference in the pop-up context menu in another app, after a long tap on a word. This is a very useful feature when I'm in the El País app.

I've just upgraded to a new phone running Android 13 and have installed Wordreference version 4.0.73. My preferences in the app are set to "goes to synonyms" for tap (mobile) and "does nothing" for long tap (mobile). When I change this to "show context menu" then the option doesn't "stick" (when I come out of preferences and go back in then it has reverted to "does nothing").

Does anyone have any idea how to fix this?

Thanks in advance.
  • I think you are talking about two different features, but they might be conflicting.

    Feature 1, in the Android app:
    Visible in Chrome and some other apps. On some site that isn't WordReference, long press a word, and context menu will open. I need to press ⋮, then choose WordReference. I then get a pop-up window with my translation.​
    Feature 2, part of the website, not the app, Preferences:
    The must be a link to this somewhere in the app, but I can't find it.​
    These preferences are for tapping and pressing within WordReference website itself. Not in Chrome or other apps.​

    Am I correct that you are talking about these two features?
    Are you saying that there is a combination of settings in the preferences that don't work?
    Are you saying that there is a (website) preference that is failing to get saved in the app?

    Thanks. If something is not working right, I hope to get it working for you and everyone.
    I've just checked and feature 1 works - I went to a Spanish-language website in Chrome on my Android phone and was able to long press a word and get to WordReference.

    Feature 2 is where I have the problem as I use apps (El País and Onda Cero) and the long press doesn't work. It used to work (at least in El País - I hadn't tried it before with Onda Cero) although it would stop working some way down a long article. A menu does appear after a long press but without WordReference as an option (I get Translate, Copiar, Seleccionar todo and then Compartir if I press the three vertical dots).

    I can't find anything in the preferences for the apps and I never (knowingly) configured anything on my old phone to make it work - I just noticed one day that it was available.

    Thanks for looking into this.
    Feature 1 is working for me in Chrome, but in other apps so far, I don't see it. Each app can control what options you get, though it is possible that Android rules have changed and now 3rd party menu options like WordReference don't appear in other apps. I will keep testing myself in various apps on my phone.

    Feature 2 really should not affect Feature 1. (Well, it would be good if the "dictionary preferences" section worked as the chosen dictionary for Feature 1.) If the tap and long tap preferences affect Feature 1, we need to fix something.

    If it isn't clear, El País and Onda Cero apps should only be affected by Feature 1. If you don't see WordReference as an option, complain to El País! It would be great if they fixed/allowed it. If something changed recently, they might not have intended it and might fix it.